Probleme d'installation sous windows

waarpr66
Tags: #<Tag:0x0000000008b911c8>

(Olivier Hudry) #1

Bonjour,

je rencontre un souci lors de l'installation du R66.
mon objectif est de pouvoir monter un simple POC entre plusieurs ordinateurs de mon équipe afin de valider le fonctionnement et commencer à déployer cette solution.
lors de l'installation, je me heurte a plusieurs soucis:
les arborescences sont étranges dans les fixhiers XML, parfois la racine est D:\GG\R66, parfois D:\GG\R66Client, comment séparer le contenu du package allinone pour ne conserver que le nécessaire sur chaque machine ?
je ne trouve a aucun endroit dans le package les outils indiqués dans la documentation: R66 admin GUI, waarp xml editor, waarp password, etc...
de plus, impossible de lancer le client GUI j'ai l'erreur suivante:

c:\GG\R66Client\bin\Windows\bin>call setvari.bat
"C:\Program Files\Java\jre1.8.0_131\bin\java" -server -Xms256m -Xmx4096m -cp " C:\GG\R66Client\lib\WaarpR66-3.0.8.jar;C:\GG\R66Client\lib* " " -Dlogback.configurationFile=C:\GG\R66Client\conf\logback-client.xml " -Dopenr66.locale=en -Dfile.encoding=UTF-8 org.waarp.openr66.r66gui.R66ClientGui "C:\GG\R66Client\/conf/config-clientA.xml"
Erreur : impossible de trouver ou charger la classe principale -Dlogback.configurationFile=C:\GG\R66Client\conf\logback-client.xml
R66 Client GUI stopped

c:\GG\R66Client\bin\Windows\bin>

j'ai mis a jour le fichier setvari.bat avec toutes les informations liées à mon environnement, mais sans succès.

cette solution me plait beaucoup pour palier a CFT et semble correspondre parfaitement à nos besoin.
je vous remercie d'avance pour votre aide

olivier


(Maxime Robert) #2

Bonjour,

Effectivement le fichier bin/setvari.bat n'a pas été modifié cela sera corrigé dans le prochain patch. La racine correcte est D:\GG\R66.
Cependant il s'agit d'une valeur à remplacer. Veuillez remplacer cette valeur par votre dossier de configuration de Waarp R66.

Waarp XMLEditor ne dispose pas d'un point d'entré via script. Pour le reste les commandes suivantes sont disponibles une fois setvari.bat exécuté:

  • R66GUI pour les interfaces clients
  • R66ADMIN pour les interfaces d'administrations

Waarp Password n'est pas encore disponible dans le package il sera bientôt livrer.

Je reste à votre disposition si vous avez plus de questions.


(Olivier Hudry) #3

bonjour,

merci pour ce retour.
cela ne m'avance cependant pas du tout.
j'ai toujours cette meme erreur après lancement du R66clGUI:
c:\EAI\R66\bin\Windows\bin>call setvari.bat
"C:\Program Files\Java\jre1.8.0_131\bin\java" -server -Xms256m -Xmx4096m -cp " C:\EAI\lib\WaarpR66-3.0.8.jar;C:\EAI\lib* " " -Dlogback.configurationFile=C:\EAI\conf\logback-client.xml " -Dopenr66.locale=en -Dfile.encoding=UTF-8 org.waarp.openr66.r66gui.R66ClientGui "C:\EAI\/conf/config-clientA.xml"
Erreur : impossible de trouver ou charger la classe principale -Dlogback.configurationFile=C:\EAI\conf\logback-client.xml
R66 Client GUI stopped

est-ce que le service R66 doit etre démarré pour lancer l'interface GUI ?
comment l'installer ?
j'ai modifié le fichier service.bat en y incluant toutes les valeurs adéquates
j'ai lancé le service install puis service start qui me rend la main.
comment s'assurer du foncitonnement du service ? c'est encore un peu obscur pour moi.
auriez vous sous la main un livrable windows qui fonctionne ?
merci encore par avance

olivier


(Maxime Robert) #4

Avez vous essayer d'enlever les espace après les "

c:\EAI\R66\bin\Windows\bin>call setvari.bat
"C:\Program Files\Java\jre1.8.0_131\bin\java" -server -Xms256m -Xmx4096m -cp "C:\EAI\lib\WaarpR66-3.0.8.jar;C:\EAI\lib*" "-Dlogback.configurationFile=C:\EAI\conf\logback-client.xml" -Dopenr66.locale=en -Dfile.encoding=UTF-8 org.waarp.openr66.r66gui.R66ClientGui "C:\EAI\/conf/config-clientA.xml"

L'utilitaire GUI est indépendant du service R66.
Vous disposez des classes java et des scripts de lancement il n'y a pas d'installation supplémentaire juste du paramétrage.
Pour s'assurer du fonctionnement du serveur R66 vous pouvez essayer d’accéder à la page de monitoring disponible sur le port configuré. (ex: http://localhost:8066).


(Olivier Hudry) #5

merci pour ce retour,

je commence a avancer dans ma compréhension de la manière dont cet outils est fait.
cependant, aucune des commandes de lancement des services ne fonctionne encore pour l'instant.
lorsque j'essaie de lancer le service, quelque chose empeche son lancement.
la seule étape que j'ai passée est celle de la création de la BDD.
j'ai installé le moteur H2, qui fonctionne, j'ai créé une base de données dessus, mais je ne trouve nulle part les scripts d'initialisation pour mettre en place le schéma de base.
je pense que la source de mon problème de service provient de la, sauriez vous ou je peux trouver ce script d'init de la BDD H2 pour le serveur R66 ?

merci encore pour votre aide


(Olivier Hudry) #6

Bonjour,

pas d'info sur l'initialisation de la BDD H2 ou postgres sous windows ?